| Forums | Sign Up | Reply | Search | Statistics | Home Page |
Online now: Guests - 2
Members - 0
Most users ever online: 5 [28 Jan 2020 07:28]
Guests - 5 / Members - 0
Integrex General integrexmachinist.com community built on miniBB / Integrex General /

Detector Malfunction error

 
Stuart
Forums Member
#1 | Posted: 8 Oct 2009 23:57
Reply 
I've been out of town for a week and just got back and tried to power up our MK1V-Matrix Controlled Integerex.

I get a No. 10 Detector alarm malfunction and a red light and I can't clear it or home the machine. The X axis is drifting as is the B axis. I pulled open the electrical cabinet and one of the Mitsubishi drives is flashing the normal startup alarms plus a 25 display. I checked the voltage in the backup battery in this drive (it's the only axis with a battery backup a Toshiba ER6VC119B - looks like an AA battery with a wire lead, but I'll bet it's not...) and it's basically dead at around .3 volts.

My guess is the alarm is telling me I've lost some type of absolute position information, or the control can't verify it as it boots. Any idea first where I can get the battery in a hurry, and second how to restore the data or parameters that have been lost, or is it neccesary.

I've got a customer on a breakdown, so I need to get running ASAP.

Thanks,

Stu
Pete
Forums Member
#2 | Posted: 9 Oct 2009 02:09
Reply 
Good luck on this thread Stu your are a Pillar here for these thing.... I know what you are feeling about... you have the competence to fix everything but, now there is a small detail missing to you and mazak will not help you, until you let enter a service guy for HOW LONG!!!! And this service guy will probably not know more than you on these machine but he have acces to MAZAK'S SERVICES BULLTINS....WHEREVER HE NEEDS IT.....
MikiMajk
Forums Member
#3 | Posted: 9 Oct 2009 03:13 | Edited by: MikiMajk
Reply 
If you have Detector mal. error, do you have also any data in brackets(), for example:
detector malfaction error ( 000342, 1, )?
regarding 25...
http://webfile.ru/3990531#
MikiMajk
Forums Member
#4 | Posted: 9 Oct 2009 03:17 | Edited by: MikiMajk
Reply 
de
Stuart
Forums Member
#5 | Posted: 9 Oct 2009 15:36 | Edited by: Stuart
Reply 
There is a bunch of data in brackets. I'm guessing it's a hexadecimal address that if I convert it to binary it will tell me the system and station # of the problem. Of course then I'd need the manual to tell me whate those are, which I don't have.

I still need to figure out if I need to, and how to restore the parameters or data that were lost when the battery failed (If that is indeed even the problem).

Oh, and I followed your link but I'm too intellectually challenged to make sense of it. I speak semi passable American english, much better Canadian eh, and I can make do in french or Spanish but I'm at a loss in any language with funny looking characters...
Stuart
Forums Member
#6 | Posted: 10 Oct 2009 11:56
Reply 
I'm back to work...yeaaaa

Seems like a lot of hassles for such a simple issue, and quite a bit of misinformation out there. It's funny when you're told there are no absolute encoders on an Integrex, yet there is a battery backing up the parameters on 1 of the axis drives. It turns out the B axis IS indexed by a servomotor that uses absolute positioning. The factory set data is stored through the use of a 3.6 volt litium battery that's a Toshiba ER6VC119B. It's a Mazak part number D50USA00160 or a Mitsubishi part # C52100. I couldn't find one locally and didn't want to be delayed waiting till after the upcoming holiday so I went to Radio shack.
Contray to what Mazak tells you, when you actually find someone who won't try to convince you that all the drives ar MRJ2 drives... sigh... you really don't need to use their battery. It is important to use a high capacity lithium cell rated around 2250 ma, rather than a generic one rated closer to 900 ma.

I bought a 3.6volt 2250 ma lithium battery and a single cell battery holder. Cut the connector off the old battery and soldered it to the leads of the battery holder. Double tape mounted it to the top of the drive and powered it up. The servo battery alarm 25 was gone.

I still had the alarm 10. This was cured by homing the machine, toggling the maintenance key, and choosing the tailstock/B axis home set softkey. Press the B axis home set and the MF1 MF2 keys and poof the alram goes away as the data is written to the drive.

Frankly I'm kind of surprised I haven't seen this issue arise before since I'd suspect the everyone with an Integrex that's a couple years old should have had this issue at least once. I suppose it's possible I just had a bad battery though...

In my preventative maintenace, I'll make it a habit to monitor this battery voltage. Once it gets down to around 3 volts it should be easy to lose the data. At least now I know the fix is as close as the nearest Radio Shack.
malc dodd
Forums Member
#7 | Posted: 30 Jan 2012 08:30
Reply 
malc dodd ex mazak service engineer
this alarm is definately the battery installed on the mds-d/mds-dh servo system
to get rid of alarm
1) with power on change battery
2) if alarm does not clear with reset key determine which axis is in alarm state by using servo monitor page and looking for 9F displayed in amp disp line (all other will have a normal state display such as d1,d2,d3etc)
3)when sure which axis is at alarm go to param then machine and feed vel (M parameters) change M16 in the relavent column by 1 eg. M16 in x set to 123456 changer to 123457 then power cnc off/on (not isolator) after power up change m16 back to original the power off/on again

fixed!
Alaska
Forums Member
#8 | Posted: 17 Jul 2014 03:15
Reply 
Recently I got this alarm on my Mazak VTC 800/30 SR after mounting two rotary tables for the first time. I found this thread and tried procedures, but none of them worked on my machine.

After a whole day of trying everything I finally was able to track down a Mazak seviceman who knew what to do. Apparently on the new Mazatrol Matrix 2 the procedure is different. It goes like this:

1. Machine parameters - for the axis you have a problem with change the bit7 in M18 parameter from 1 to 0.
2. Restart the machine.
3. After restart press the "home" mode on the panel and hold the jog button of the axis (for example -B). The axis will rotate few degrees and find it's zero point (it might change the direction of rotation, don't worry, it's a normal procedure). When the axis is zeroed, zero all the other axes and set the bit7 in parameter M18 from 0 to 1 and restart the machine.
4. After restart you will probably get alarm No. 9 - Absolute position malfunction. Again press the "home" mode on the panel and again press and hold job button of the axis. When the axis is zeroed, zero all the other axes and turn off the controller and also the whole machine with the main switch. Wait for 2 minutes.
5. Turn the machine again, the problem should be solved.

Still wondering why the didn't put it in the instruction manual...
Jan_Pio
Forums Member
#9 | Posted: 3 Mar 2015 06:39
Reply 
Hi Alaska
I have similar problem on the same machine with B axis. I tried your procedure, but it doesn't work. Is there anything that you could miss writing your post?
 

:);):-p:-(More smilies...  Disable smilies in post
Your reply
Bold Style  Italic Style  Image Link  URL Link 

» Username  » Password 
Only registered users are allowed to post here. Please enter your login/password details upon posting a message, or sign up first.
 

Forums are powered by miniBB®